Uploaded image for project: 'Qt'
  1. Qt
  2. QTBUG-72857

QNetworkAccessManager::authenticationRequired problems with SSL

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Reported
    • Priority: P3: Somewhat important
    • Resolution: Unresolved
    • Affects Version/s: 5.11, 5.12.0
    • Fix Version/s: None
    • Component/s: Network: HTTP, Network: SSL
    • Labels:
      None

      Description

      I tried to access a PHP file which is in a htaccess restricted area of a Webserver which use HTTPS. In my example I tried it with AuthType Basic

      The authenticationRequired() signal is triggered every few seconds. In the connected slot I set the username and password of the restricted area on the QAuthenticator object.

      The log from the server shows that the request (which is a normal GET request), I also tried POST request, is sent a multiply of 100 per second so ~= 200 requests per second until the server give up.

      It seems that the problem only occurs in combination of ssl and a restricted area

      There are no error, sslerror or finished signals emitted, but I see the traffic in Wireshark.
      The problem occurs on Windows, Mac and iOS.

      When I enter the url in the browser, then it is working without a problem.

        Attachments

        No reviews matched the request. Check your Options in the drop-down menu of this sections header.

          Activity

            People

            • Assignee:
              cnn Qt Core & Network
              Reporter:
              roman80 Roman W├╝ger
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:

                Gerrit Reviews

                There are no open Gerrit changes