Uploaded image for project: 'Qt'
  1. Qt
  2. QTBUG-73018

CONFIG += windeployqt doesn't work

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: P2: Important
    • Resolution: Done
    • Affects Version/s: 5.12.0
    • Fix Version/s: 5.12.1, 5.14.0 Alpha
    • Component/s: Build tools: qmake
    • Labels:
      None
    • Environment:
      Win10 17763.253, MSVC2017 15.9.5
    • Platform/s:
      Windows
    • Commits:
      af821f79cacbac0be9995a7eb4a0448a9a2958bf (qt/qtbase/5.12.1)

      Description

      I added "CONFIG += windeployqt" to my .pro files and qmake generated the following error messages:

      Cannot add commands to previously defined target debug-windeployqt_clean.
      Cannot add commands to previously defined target release-windeployqt_clean.
      

      The windeployqt tool was not executed after compiling either.

        Attachments

          Issue Links

          No reviews matched the request. Check your Options in the drop-down menu of this sections header.

            Activity

              People

              Assignee:
              qtbuildsystem Qt Build System Team
              Reporter:
              wangwenx190 赵 宇航
              Votes:
              0 Vote for this issue
              Watchers:
              7 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved:

                  Gerrit Reviews

                  There are no open Gerrit changes