Uploaded image for project: 'Qt'
  1. Qt
  2. QTBUG-73048

Turn on deprecation warnings by default

    XMLWordPrintable

    Details

    • Type: Task
    • Status: Closed
    • Priority: P1: Critical
    • Resolution: Done
    • Affects Version/s: 5.13.0
    • Fix Version/s: 5.13.0
    • Component/s: Build System
    • Labels:
      None
    • Platform/s:
      All

      Description

      We should enable deprecation warnings by default to make people aware of API changes and ease porting to future Qt versions (think Qt 6).

        Attachments

        No reviews matched the request. Check your Options in the drop-down menu of this sections header.

          Activity

            People

            Assignee:
            peppe Giuseppe D'Angelo
            Reporter:
            frederik Frederik Gladhorn
            Votes:
            0 Vote for this issue
            Watchers:
            5 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:

                Gerrit Reviews

                There are no open Gerrit changes