Uploaded image for project: 'Qt'
  1. Qt
  2. QTBUG-73299

qtquickcontrols2 fails to build for nonnative arch if system has older version of library

    XMLWordPrintable

Details

    • Bug
    • Status: Closed
    • P2: Important
    • Resolution: Duplicate
    • 5.11.1, 5.11.3
    • None
    • None
    • Gentoo Linux x86_64 (amd64)
    • Linux/X11

    Description

      I'm using gentoo, and when updating qtquickcontrols2 from version 5.11.1 to 5.11.3, building both x86_64 and x86_32 versions, I'm getting following error:

      .obj/qquicktumblerview.o: In function `QQuickTumblerView::updateModel()':
      qquicktumblerview.cpp:(.text+0x296): undefined reference to `QQuickTumblerPrivate::beginSetModel()'
      qquicktumblerview.cpp:(.text+0x2ac): undefined reference to `QQuickTumblerPrivate::endSetModel()'
      

      The build command which fails:

      x86_64-pc-linux-gnu-g++ -m32 -Wl,-O1 -Wl,--as-needed -Wl,--no-undefined -Wl,--version-script,QtQuickControls2.version -Wl,--enable-new-dtags -shared -Wl,-Bsymbolic-functions -Wl,-soname,libQt5QuickControls2.so.5 -o libQt5QuickControls2.so.5.11.3 .obj/qquickanimatednode.o .obj/qquickattachedobject.o .obj/qquickchecklabel.o .obj/qquickclippedtext.o .obj/qquickcolor.o .obj/qquickcolorimage.o .obj/qquickiconimage.o .obj/qquickiconlabel.o .obj/qquickitemgroup.o .obj/qquickmnemoniclabel.o .obj/qquickpaddedrectangle.o .obj/qquickplaceholdertext.o .obj/qquickproxytheme.o .obj/qquickstyle.o .obj/qquickstyleplugin.o .obj/qquickstyleselector.o .obj/qquicktheme.o .obj/qquicktumblerview.o .obj/moc_qquickanimatednode_p.o .obj/moc_qquickattachedobject_p.o .obj/moc_qquickchecklabel_p.o .obj/moc_qquickclippedtext_p.o .obj/moc_qquickcolor_p.o .obj/moc_qquickcolorimage_p.o .obj/moc_qquickiconimage_p.o .obj/moc_qquickiconlabel_p.o .obj/moc_qquickitemgroup_p.o .obj/moc_qquickmnemoniclabel_p.o .obj/moc_qquickpaddedrectangle_p.o .obj/moc_qquickplaceholdertext_p.o .obj/moc_qquickstyleplugin_p.o .obj/moc_qquicktumblerview_p.o  -L/usr/lib32 -lQt5Quick -lQt5Gui -lQt5Qml -lQt5Network -lQt5Core -lpthread -L/tmp/portage/portage/dev-qt/qtquickcontrols2-5.11.3/work/qtquickcontrols2-everywhere-src-5.11.3-abi_x86_32.x86/lib -lQt5QuickTemplates2 -L/usr/lib32 -lQt5Quick -lQt5Gui -lQt5Qml -lQt5Network -lQt5Core -lpthread -lGL 
      

      Looks like issue appears due to specification of -L/usr/lib32 before -L/tmp/portage/portage/dev-qt/qtquickcontrols2-5.11.3/work/qtquickcontrols2-everywhere-src-5.11.3-abi_x86_32.x86/lib where new just built library Qt5QuickTemplates2 is located, and old one is used instead.

      Updates between other versions could be affected as well.

      Attachments

        Issue Links

          No reviews matched the request. Check your Options in the drop-down menu of this sections header.

          Activity

            People

              qtbuildsystem Qt Build System Team
              i.dark_templar i.dark_templar
              Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved:

                Gerrit Reviews

                  There are no open Gerrit changes