Uploaded image for project: 'Qt'
  1. Qt
  2. QTBUG-74526

Qt hard-requires a minimum kernel version due to statx availability

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Not Evaluated
    • Resolution: Done
    • Affects Version/s: 5.11.3, 5.12.0, 5.12.1, 5.12.2
    • Fix Version/s: 5.12.3, 5.14.0 Alpha
    • Component/s: Core: I/O
    • Labels:
      None
    • Platform/s:
      Linux/X11, Linux/Wayland, Linux/Other display system
    • Commits:
      7148dfc67ff20c1c625d203aa47b574b3aaa5db1 (qt/qtbase/5.12)

      Description

      As of commit b7887f9b4faad2227691a2af589e9d7680d6ae08, if statx is available during the ./configure stage, it hardcodes a minimum kernel version of 4.11.0.

      This means the library can't be loaded if you're using an older version of the kernel.

      However, glibc has fallback code if statx is not available during runtime, so the minimum kernel version is not really necessary.

        Attachments

        For Gerrit Dashboard: QTBUG-74526
        # Subject Branch Project Status CR V

          Activity

            People

            • Assignee:
              thiago Thiago Macieira
              Reporter:
              vogtinator Fabian Vogt
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Gerrit Reviews

                There are no open Gerrit changes