Uploaded image for project: 'Qt'
  1. Qt
  2. QTBUG-75098

Absolute paths to EGL library in libQt5Gui.so

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Reported
    • Priority: P3: Somewhat important
    • Resolution: Unresolved
    • Affects Version/s: 5.12.2
    • Fix Version/s: None
    • Component/s: Build System
    • Labels:
      None
    • Environment:
      Host: Linux
      X-Platform: ARM Cortex A8 (TI AM3359)
    • Platform/s:
      Linux/Other display system

      Description

      Since Qt 5.12.2 (and possibly 5.12.1, but I didn't try), when I cross compile qtbase
      to an AM3359 platform, some libraries that link to OpenGL (e.g. libQt5Gui.so) have absolute paths as dependencies. The Qt platform on the target is eglfs.

      There is a related bug report QTBUG-72903. I also posted the question already in the forum [0].

      Here is the output from readelf -d libQt5Gui.so

       0x00000001 (NEEDED)                     Shared library: [libQt5Core.so.5]
       0x00000001 (NEEDED)                     Shared library: [libz.so.1]
       0x00000001 (NEEDED)                     Shared library: [libpthread.so.0]
       0x00000001 (NEEDED)                     Shared library: [/home/work/sdk/sysroot/usr/lib/libEGL.so]
       0x00000001 (NEEDED)                     Shared library: [/home/work/sdk/sysroot/usr/lib/libIMGegl.so]
       0x00000001 (NEEDED)                     Shared library: [/home/work/sdk/sysroot/usr/lib/libsrv_um.so]
       0x00000001 (NEEDED)                     Shared library: [/home/work/sdk/sysroot/usr/lib/libGLESv2.so]
       0x00000001 (NEEDED)                     Shared library: [/home/work/sdk/sysroot/usr/lib/libGLES_CM.so]
       0x00000001 (NEEDED)                     Shared library: [/home/work/sdk/sysroot/usr/lib/libusc.so]
       0x00000001 (NEEDED)                     Shared library: [libstdc++.so.6]
       0x00000001 (NEEDED)                     Shared library: [libm.so.6]
       0x00000001 (NEEDED)                     Shared library: [libgcc_s.so.1]
       0x00000001 (NEEDED)                     Shared library: [libc.so.6]
       0x0000000e (SONAME)                     Library soname: [libQt5Gui.so.5]
      

      The relevant part in my mkspecs/qmake.conf file is as follows
       

      QMAKE_LIBDIR_OPENGL_ES2 = $$[QT_SYSROOT]/usr/lib
      QMAKE_LIBDIR_EGL        = $$QMAKE_LIBDIR_OPENGL_ES2
      
      QMAKE_INCDIR_EGL        = $$[QT_SYSROOT]/usr/include
      QMAKE_INCDIR_OPENGL_ES2 = $${QMAKE_INCDIR_EGL}
      
      QMAKE_LIBS_OPENGL_ES2   = -lEGL -lIMGegl -lsrv_um -lGLESv2 -lGLES_CM -lusc
      QMAKE_LIBS_EGL          = $${QMAKE_LIBS_OPENGL_ES2}
      

      [0]: https://forum.qt.io/topic/101590/absolute-paths-to-egl-library-in-libqt5gui-so-since-qt-5-12-1

        Attachments

          Issue Links

          No reviews matched the request. Check your Options in the drop-down menu of this sections header.

            Activity

              People

              • Assignee:
                qtbuildsystem Qt Build System Team
                Reporter:
                eglimi Michael Egli
              • Votes:
                5 Vote for this issue
                Watchers:
                7 Start watching this issue

                Dates

                • Created:
                  Updated:

                  Gerrit Reviews

                  There are no open Gerrit changes