Uploaded image for project: 'Qt'
  1. Qt
  2. QTBUG-76884

OpenSSL 1.1.1 not working on Android API 21

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: P0: Blocker
    • Resolution: Fixed
    • Affects Version/s: 5.12.4, 5.13.0
    • Fix Version/s: 5.12.5, 5.13.1, 5.14.0 Alpha
    • Component/s: Network: SSL
    • Labels:
      None
    • Platform/s:
      Android
    • Commits:
      698faf7b6de08bed2aa7e345982cedd907353e11

      Description

      I Reopen because Qt should fully support Android API 21.

      I add a small project, In wich you find the KDAB libs

      What I did is

      1. Open Android Studio
      2. Create AVD 1: Pixel 2 5.0, image x86 Lollipop, API 21, Android 5.0 (Google APIs)
      3. Create AVD 2: Pixel 2 5.0, Recommended image x86 Q, API 29, Android 9.+ (Google Play)
      4. With Qt Creator, compile and run the annexed project with Qt 5.12.4 Android x86
      5. Click on the button "Download https google" to start the test

      application.zip

      And this is the result I get

      The same error happens also on ARM using a Samsung Galaxy S8 (working) and a Samsung J3 2016 (not working)

        Attachments

        1. android-ssl-compare.png
          android-ssl-compare.png
          87 kB
        2. application.zip
          5.09 MB

          Issue Links

          No reviews matched the request. Check your Options in the drop-down menu of this sections header.

            Activity

              People

              • Assignee:
                taipan BogDan Vatra
                Reporter:
                joz José Del Romano
              • Votes:
                2 Vote for this issue
                Watchers:
                10 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:

                  Gerrit Reviews

                  There are no open Gerrit changes