Uploaded image for project: 'Qt'
  1. Qt
  2. QTBUG-76993

WebGL plugin does not work since RHI landed in qtbase and qtdeclarative

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: P1: Critical
    • Resolution: Done
    • Affects Version/s: 5.14
    • Fix Version/s: 5.14
    • Component/s: QPA: WebGL
    • Labels:
      None
    • Environment:
      Tested on macOS 10.14
    • Platform/s:
      All
    • Commits:
      e51341cf20447c42a62281e633513837058f62e5

      Description

      Qt WebGL QPA plugin stopped working since RHI support landed, specifically the following commit. https://codereview.qt-project.org/c/qt/qtdeclarative/+/259447

      How to reproduce:
      1) set environment variable QT_QPA_PLATFORM=webgl
      2) Start qtbase/bin/qmlscene qt_source/qtwebglplugin/tests/plugins/platforms/webgl/basic_scene.qml
      3) Open browser supporting webgl and point to 127.0.0.1:8080 (I used Chrome)
      4) Observe endless loading spinner animation.

      More details in the WIP commit I will push

        Attachments

        No reviews matched the request. Check your Options in the drop-down menu of this sections header.

          Activity

            People

            Assignee:
            lagocs Laszlo Agocs
            Reporter:
            alexandru.croitor Alexandru Croitor
            Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:

                Gerrit Reviews

                There are no open Gerrit changes