Uploaded image for project: 'Qt'
  1. Qt
  2. QTBUG-77387

WebEngine won't be built with Python 2.7.10 or later

    XMLWordPrintable

    Details

    • Platform/s:
      macOS

      Description

      If Python 2.7.10 or later is installed on system, configure can't find that.

      $python --version
      Python 2.7.10
      

       

      Showing running configure:

      WARNING: Python version 2 (2.7.5 or later) is required to build QtWebEngine.
      

      Showing to start building WebEngine:

      cd qtwebengine/ && ( test -e Makefile || /Users/akihitoi/Qt/5.13.0/Src/build/qtbase/bin/qmake -o Makefile /Users/akihitoi/Qt/5.13.0/Src/qtwebengine/qtwebengine.pro ) && /Applications/Xcode.app/Contents/Developer/usr/bin/make -f Makefile
      A suitable version of python2 could not be found.
      QtWebEngine will not be built.
      

       

      Python 2.7.10 is default on macOS 10.14 Mojave, that have to be downgraded to 2.7.9. If latest 2.7.16 is installed, won't work.

        Attachments

        No reviews matched the request. Check your Options in the drop-down menu of this sections header.

          Activity

            People

            Assignee:
            kkohne Kai Köhne
            Reporter:
            akizawa Akihito Izawa
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:

                Gerrit Reviews

                There are no open Gerrit changes