Uploaded image for project: 'Qt'
  1. Qt
  2. QTBUG-78810

macOS: gss_* deprecated, should be replaced by use of GSS.framework

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: P3: Somewhat important
    • Resolution: Done
    • Affects Version/s: 5.14
    • Fix Version/s: 5.14
    • Labels:
      None
    • Platform/s:
      macOS
    • Commits:
      b7a915398a2ee928df4db2c5dd8e308f480c7906

      Description

      /Users/torarne/dev/qt/5.14/qtbase/src/network/kernel/qauthenticator.cpp:1612:9: warning: 'gss_display_status' is deprecated: use GSS.framework [-Wdeprecated-declarations]
       gss_display_status(&minStat, stat, type, GSS_C_NO_OID, &msgCtx, &msg);
       ^
      /Applications/Xcode.app/Contents/Developer/Platforms/MacOSX.platform/Developer/SDKs/MacOSX10.15.sdk/usr/include/gssapi/gssapi.h:561:19: note: 'gss_display_status' has been explicitly marked deprecated here
       gss_buffer_t) GSSKRB_APPLE_DEPRECATED("use GSS.framework") __API_DEPRECATED("Use GSS.framework", macos(10.0, 10.8)) __API_UNAVAILABLE(macCatalyst); /* status_string */
       ^
      /Applications/Xcode.app/Contents/Developer/Platforms/MacOSX.platform/Developer/SDKs/MacOSX10.15.sdk/usr/include/gssapi/gssapi.h:57:51: note: expanded from macro 'GSSKRB_APPLE_DEPRECATED'
      #define GSSKRB_APPLE_DEPRECATED(x) __attribute__((deprecated(x)))
       ^
      /Users/torarne/dev/qt/5.14/qtbase/src/network/kernel/qauthenticator.cpp:1614:9: warning: 'gss_release_buffer' is deprecated: use GSS.framework [-Wdeprecated-declarations]
       gss_release_buffer(&minStat, &msg);
       ^
      /Applications/Xcode.app/Contents/Developer/Platforms/MacOSX.platform/Developer/SDKs/MacOSX10.15.sdk/usr/include/gssapi/gssapi.h:601:19: note: 'gss_release_buffer' has been explicitly marked deprecated here
       gss_buffer_t) GSSKRB_APPLE_DEPRECATED("use GSS.framework") __API_DEPRECATED("Use GSS.framework", macos(10.0, 10.8)) __API_UNAVAILABLE(macCatalyst); /* buffer */
       ^
      /Applications/Xcode.app/Contents/Developer/Platforms/MacOSX.platform/Developer/SDKs/MacOSX10.15.sdk/usr/include/gssapi/gssapi.h:57:51: note: expanded from macro 'GSSKRB_APPLE_DEPRECATED'
      #define GSSKRB_APPLE_DEPRECATED(x) __attribute__((deprecated(x)))
       ^
      /Users/torarne/dev/qt/5.14/qtbase/src/network/kernel/qauthenticator.cpp:1640:15: warning: 'gss_import_name' is deprecated: use GSS.framework [-Wdeprecated-declarations]
       majStat = gss_import_name(&minStat, &nameDesc,
       ^
      /Applications/Xcode.app/Contents/Developer/Platforms/MacOSX.platform/Developer/SDKs/MacOSX10.15.sdk/usr/include/gssapi/gssapi.h:591:19: note: 'gss_import_name' has been explicitly marked deprecated here
       gss_name_t *) GSSKRB_APPLE_DEPRECATED("use GSS.framework") __API_DEPRECATED("Use GSS.framework", macos(10.0, 10.8)) __API_UNAVAILABLE(macCatalyst); /* output_name */
       ^
      /Applications/Xcode.app/Contents/Developer/Platforms/MacOSX.platform/Developer/SDKs/MacOSX10.15.sdk/usr/include/gssapi/gssapi.h:57:51: note: expanded from macro 'GSSKRB_APPLE_DEPRECATED'
      #define GSSKRB_APPLE_DEPRECATED(x) __attribute__((deprecated(x)))
       ^
      /Users/torarne/dev/qt/5.14/qtbase/src/network/kernel/qauthenticator.cpp:1667:15: warning: 'gss_init_sec_context' is deprecated: use GSS.framework [-Wdeprecated-declarations]
       majStat = gss_init_sec_context(&minStat,
       ^
      /Applications/Xcode.app/Contents/Developer/Platforms/MacOSX.platform/Developer/SDKs/MacOSX10.15.sdk/usr/include/gssapi/gssapi.h:475:18: note: 'gss_init_sec_context' has been explicitly marked deprecated here
       OM_uint32 *) GSSKRB_APPLE_DEPRECATED("use GSS.framework") __API_DEPRECATED("Use GSS.framework", macos(10.0, 10.8)) __API_UNAVAILABLE(macCatalyst); /* time_rec */
       ^
      /Applications/Xcode.app/Contents/Developer/Platforms/MacOSX.platform/Developer/SDKs/MacOSX10.15.sdk/usr/include/gssapi/gssapi.h:57:51: note: expanded from macro 'GSSKRB_APPLE_DEPRECATED'
      #define GSSKRB_APPLE_DEPRECATED(x) __attribute__((deprecated(x)))
       ^
      /Users/torarne/dev/qt/5.14/qtbase/src/network/kernel/qauthenticator.cpp:1683:5: warning: 'gss_release_buffer' is deprecated: use GSS.framework [-Wdeprecated-declarations]
       gss_release_buffer(&ignored, &outBuf);
       ^
      /Applications/Xcode.app/Contents/Developer/Platforms/MacOSX.platform/Developer/SDKs/MacOSX10.15.sdk/usr/include/gssapi/gssapi.h:601:19: note: 'gss_release_buffer' has been explicitly marked deprecated here
       gss_buffer_t) GSSKRB_APPLE_DEPRECATED("use GSS.framework") __API_DEPRECATED("Use GSS.framework", macos(10.0, 10.8)) __API_UNAVAILABLE(macCatalyst); /* buffer */
       ^
      /Applications/Xcode.app/Contents/Developer/Platforms/MacOSX.platform/Developer/SDKs/MacOSX10.15.sdk/usr/include/gssapi/gssapi.h:57:51: note: expanded from macro 'GSSKRB_APPLE_DEPRECATED'
      #define GSSKRB_APPLE_DEPRECATED(x) __attribute__((deprecated(x)))
       ^
      /Users/torarne/dev/qt/5.14/qtbase/src/network/kernel/qauthenticator.cpp:1687:9: warning: 'gss_release_name' is deprecated: use GSS.framework [-Wdeprecated-declarations]
       gss_release_name(&ignored, &ctx->gssApiHandles->targetName);
       ^
      /Applications/Xcode.app/Contents/Developer/Platforms/MacOSX.platform/Developer/SDKs/MacOSX10.15.sdk/usr/include/gssapi/gssapi.h:596:19: note: 'gss_release_name' has been explicitly marked deprecated here
       gss_name_t *) GSSKRB_APPLE_DEPRECATED("use GSS.framework") __API_DEPRECATED("Use GSS.framework", macos(10.0, 10.8)) __API_UNAVAILABLE(macCatalyst); /* input_name */
       ^
      /Applications/Xcode.app/Contents/Developer/Platforms/MacOSX.platform/Developer/SDKs/MacOSX10.15.sdk/usr/include/gssapi/gssapi.h:57:51: note: expanded from macro 'GSSKRB_APPLE_DEPRECATED'
      #define GSSKRB_APPLE_DEPRECATED(x) __attribute__((deprecated(x)))
       ^
      /Users/torarne/dev/qt/5.14/qtbase/src/network/kernel/qauthenticator.cpp:1689:13: warning: 'gss_delete_sec_context' is deprecated: use GSS.framework [-Wdeprecated-declarations]
       gss_delete_sec_context(&ignored, &ctx->gssApiHandles->gssCtx, GSS_C_NO_BUFFER);
       ^
      /Applications/Xcode.app/Contents/Developer/Platforms/MacOSX.platform/Developer/SDKs/MacOSX10.15.sdk/usr/include/gssapi/gssapi.h:502:19: note: 'gss_delete_sec_context' has been explicitly marked deprecated here
       gss_buffer_t) GSSKRB_APPLE_DEPRECATED("use GSS.framework") __API_DEPRECATED("Use GSS.framework", macos(10.0, 10.8)) __API_UNAVAILABLE(macCatalyst); /* output_token */
       ^
      /Applications/Xcode.app/Contents/Developer/Platforms/MacOSX.platform/Developer/SDKs/MacOSX10.15.sdk/usr/include/gssapi/gssapi.h:57:51: note: expanded from macro 'GSSKRB_APPLE_DEPRECATED'
      #define GSSKRB_APPLE_DEPRECATED(x) __attribute__((deprecated(x)))
       ^
      /Users/torarne/dev/qt/5.14/qtbase/src/network/kernel/qauthenticator.cpp:1694:9: warning: 'gss_release_name' is deprecated: use GSS.framework [-Wdeprecated-declarations]
       gss_release_name(&ignored, &ctx->gssApiHandles->targetName);
       ^
      /Applications/Xcode.app/Contents/Developer/Platforms/MacOSX.platform/Developer/SDKs/MacOSX10.15.sdk/usr/include/gssapi/gssapi.h:596:19: note: 'gss_release_name' has been explicitly marked deprecated here
       gss_name_t *) GSSKRB_APPLE_DEPRECATED("use GSS.framework") __API_DEPRECATED("Use GSS.framework", macos(10.0, 10.8)) __API_UNAVAILABLE(macCatalyst); /* input_name */
       ^
      /Applications/Xcode.app/Contents/Developer/Platforms/MacOSX.platform/Developer/SDKs/MacOSX10.15.sdk/usr/include/gssapi/gssapi.h:57:51: note: expanded from macro 'GSSKRB_APPLE_DEPRECATED'
      #define GSSKRB_APPLE_DEPRECATED(x) __attribute__((deprecated(x)))
       ^
      8 warnings generated.

        Attachments

        No reviews matched the request. Check your Options in the drop-down menu of this sections header.

          Activity

            People

            Assignee:
            tpochep Timur Pocheptsov
            Reporter:
            vestbo Tor Arne Vestbø
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:

                Gerrit Reviews

                There are no open Gerrit changes