Uploaded image for project: 'Qt'
  1. Qt
  2. QTBUG-79057

Qt Wayland does not build (but configuration still passes)

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: P1: Critical
    • Resolution: Done
    • Affects Version/s: 5.15
    • Fix Version/s: None
    • Labels:
      None
    • Platform/s:
      Linux/Wayland
    • Commits:
      a694ae228ee1779b1c6ec3cae8f1178dea6d7a5d (qt/qtwayland/5.15)

      Description

      The configuration tests for wayland-client and wayland-egl were deleted in https://codereview.qt-project.org/c/qt/qtwayland/+/274421 . Unfortunately, some tests were not converted to inline format, but were still deleted. So they will now fail because they can't be found.

      Unfortunately, the way configuration works, is that it will happily build nothing if the configure tests for libwayland fails (no errors, green coin builds).

      In short: qtwayland client and compositor modules are not currently built, nor tested in the 5.15 and dev branches.

        Attachments

        No reviews matched the request. Check your Options in the drop-down menu of this sections header.

          Activity

            People

            • Assignee:
              johanhelsing Johan Helsing
              Reporter:
              johanhelsing Johan Helsing
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Gerrit Reviews

                There are no open Gerrit changes