Uploaded image for project: 'Qt'
  1. Qt
  2. QTBUG-79487

stopping QMediaPlayer on i.MX6 hangs main thread

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: P2: Important
    • Resolution: Won't Do
    • Affects Version/s: 5.12.5
    • Fix Version/s: None
    • Component/s: Multimedia
    • Labels:
      None
    • Platform/s:
      Linux/Other display system

      Description

      I have an Quick EGL application on i.MX6Q (Vivante drivers). The audio playback is moved to it's own thread. When I now play some audio and the audio stops because the playlist is finished I see a lot of frame drops (delay seems ~0.4s from rough measurements). When I run strace I see that the audio device is flushed and closed at this point, which seems to block the main thread.

      I would like to get entirely rid of that cleanup for the moment, I only have one application and that will later reuse the QMediaPlayer and could benefit from the device still being open and ready. Even hackish things welcome, just give me a pointer where that unref happens.

      The more general question is how to get the thing properly closed without blocking the UI…

        Attachments

        1. backtrace
          22 kB
        2. reduced.str
          27 kB
        No reviews matched the request. Check your Options in the drop-down menu of this sections header.

          Activity

            People

            Assignee:
            valentyn.doroshchuk Valentyn Doroshchuk
            Reporter:
            rebemlix Rolf Eike Beer
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:

                Gerrit Reviews

                There are no open Gerrit changes