Uploaded image for project: 'Qt'
  1. Qt
  2. QTBUG-79555

Upgrade PostgreSQL library for Qt build configurations

    XMLWordPrintable

    Details

    • Platform/s:
      Windows

      Description

      According to the site, the latest versions of Qt for Windows are still being built with libpq version 9.1.9, which is no longer supported.

      https://wiki.qt.io/Qt_5.14_Tools_and_Versions
       
      Please update the PostgreSQL library used to build new Qt releases.

      The upgrade is also necessary so that you can use  forward-only mode in SQL queries.
      See commit: 210952  f99d2b21b8fc867f0ed21dcbfa47865ad013db97

      Currently, to use the forward-only mode, you need to recompile the QPSQL plugin with libpq library version at least 9.2.

        Attachments

        No reviews matched the request. Check your Options in the drop-down menu of this sections header.

          Activity

            People

            Assignee:
            hehalmet Heikki Halmet
            Reporter:
            amiart Robert Szefner
            Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:

                Gerrit Reviews

                There are no open Gerrit changes