Uploaded image for project: 'Qt'
  1. Qt
  2. QTBUG-79844

can not use zstd compression with Qt 5.13.2

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Reported
    • Priority: P3: Somewhat important
    • Resolution: Unresolved
    • Affects Version/s: 5.13.2, 5.15.0
    • Fix Version/s: None
    • Component/s: Build tools: rcc
    • Labels:
      None
    • Environment:
      Windows 10, Qt 5.13.2, Qt 5.15.0
    • Platform/s:
      Windows

      Description

      The Qt 5.13.1 release notes state that "zstd" compression is not used by default, but can be used by passing "--compress-algo=zstd" to rcc.exe.

      Tried adding

      QMAKE_RESOURCE_FLAGS += -compress-algo zstd

      and 

      QMAKE_RESOURCE_FLAGS += --compress-algo=zstd

       

      But either resulted in the error message below:

      dependent 'Usage: C:\Qt\5.13.2\msvc2017_64\bin\rcc.exe [options] inputs' does not exist.

       

      UPDATE: for Qt 5.15.0 the error message now is: "Qt\5.15.0\msvc2019_64\bin\rcc.exe: Zstandard support not compiled in".

       

        Attachments

        No reviews matched the request. Check your Options in the drop-down menu of this sections header.

          Activity

            People

            Assignee:
            hjk hjk
            Reporter:
            ev E Visser
            Votes:
            1 Vote for this issue
            Watchers:
            4 Start watching this issue

              Dates

              Created:
              Updated:

                Gerrit Reviews

                There are no open Gerrit changes