Uploaded image for project: 'Qt'
  1. Qt
  2. QTBUG-80032

no LC_RPATH load command

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: P1: Critical
    • Resolution: Incomplete
    • Affects Version/s: 5.13.2
    • Fix Version/s: None
    • Labels:
      None
    • Platform/s:
      macOS

      Description

      After I call macdeployqt on the application bundle the used Qt frameworks are added with @rpath...

      When i try to package the application bundle I get the following error:

      error: /Applications/Xcode.app/Contents/Developer/Toolchains/XcodeDefault.xctoolchain/usr/bin/install_name_tool: no LC_RPATH load command with path: /opt/Qt/5.13.2/clang_64/lib
      (for architecture x86_64), required for specified option "-delete_rpath /opt/Qt/5.13.2/clang_64/lib"

       

      It worked already in a previous version of Qt but in the previous version the Qt frameworks are added with @executable_path

        Attachments

        No reviews matched the request. Check your Options in the drop-down menu of this sections header.

          Activity

            People

            Assignee:
            Unassigned Unassigned
            Reporter:
            roman80 Roman Wüger
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:

                Gerrit Reviews

                There are no open Gerrit changes