Uploaded image for project: 'Qt'
  1. Qt
  2. QTBUG-80312

Create Qt5Compat and move Qt5 API's as see fit

    XMLWordPrintable

    Details

    • Type: User Story
    • Status: Closed
    • Priority: P1: Critical
    • Resolution: Done
    • Affects Version/s: None
    • Fix Version/s: 6.0.0, 6.0
    • Component/s: Core: Other
    • Labels:
      None
    • Platform/s:
      All
    • Epic Link:
    • Story Points:
      21
    • Sprint:
      Qt6_Foundation_ Sprint 6

      Description

      The following Qt5 classes won't be longer maintained in Qt6 and shall be moved to Qt5Compat:

      • For sure:
        • QLinkedList
        • QRegExp (may have to wait until qmake bootstrapping was removed)
      • maybe:
        • QStringRef
        • Old QList
        • QJsonDocument::fromBinaryData()

      The Compat lib should introduce a Qt5 namespace.

        Attachments

          Issue Links

          No reviews matched the request. Check your Options in the drop-down menu of this sections header.

            Activity

              People

              Assignee:
              sonakur Sona Kurazyan
              Reporter:
              ablasche Alex Blasche
              PM Owner:
              Maurice Kalinowski Maurice Kalinowski
              RnD Owner:
              Alex Blasche Alex Blasche
              Votes:
              0 Vote for this issue
              Watchers:
              10 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved:

                  Gerrit Reviews

                  There are no open Gerrit changes