Uploaded image for project: 'Qt'
  1. Qt
  2. QTBUG-81521

QWebEnginePage::Back/Forward button doesn't become enabled when <frame>/<iframe> is updated

    XMLWordPrintable

    Details

    • Platform/s:
      All
    • Commits:
      d7d40469b5bfad2cc1693ef663864d2b15d59687 (qt/qtwebengine/5.14) 2f56fd4a6b9b6f806334ba64b3689151a78d1d90 (qt/qtwebengine/5.12)

      Description

      QWebEnginePage::Back/Forward button doesn't become enabled when <frame>/<iframe> is updated.

      How to reproduce :
      1. Run the attached sample code (QTBUG81512.zip) with the parameter “test\frame\index.html”
      2. Click one of the links on the left side. e.g. "right2" -> In the right view, the frame is switched to right2.

      Expected behavior:
      Back button in the menu bar becomes green and enabled.

      Actual behavior
      The button stays gray and disabled.

      The button works when

      • Click the link "Qt" on the left side. This enables to trace all the action history up to the beginning. That is, the right side changes Qt -> right2 -> right1
      • Click right mouse on the left side, This shows a menu where the back button is enabled. ( See webEngineHistory.png )

      The same thing can be tested for <iframe> with the parameter "test\iframe\index.html"

        Attachments

        No reviews matched the request. Check your Options in the drop-down menu of this sections header.

          Activity

            People

            Assignee:
            pvarga Peter Varga
            Reporter:
            nagrohn Nahomi Gröhn
            Votes:
            1 Vote for this issue
            Watchers:
            2 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:

                Gerrit Reviews

                There are no open Gerrit changes