Uploaded image for project: 'Qt'
  1. Qt
  2. QTBUG-81761

[REG 5.14.0-5.14.1] Unable to compile with gcc-4.9

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: P1: Critical
    • Resolution: Out of scope
    • Affects Version/s: 5.14.1
    • Fix Version/s: None
    • Component/s: Build tools: Other
    • Labels:
      None
    • Platform/s:
      Linux/X11

      Description

      I installed Qt 5.14.1 on Centos-7 a few days ago, but the problem I'm facing is nothing will build. Not even the included examples. They all fail with the following warning:

      #error “Qt requires C++11 support”

      I have tried the obvious fixes that came up when googling, but they have no effect:

      CONFIG = c+11

      QMAKE_CXXFLAGS = -std=c+11

       

      Other versions of Qt (5.12.4, 5.12.6) work just fine, but unfortunately I need a bug fix in 5.14.1.

       

      Here is some relevant information to my system:

       

      cat /etc/os-release

      NAME="CentOS Linux"
      VERSION="7 (Core)"
      ID="centos"
      ID_LIKE="rhel fedora"
      VERSION_ID="7"
      uname -r
      3.10.0-693.21.1.el7.x86_64

      gcc --version
      gcc (GCC) 4.8.5 20150623 (Red Hat 4.8.5-39)

      Copyright (C) 2015 Free Software Foundation, Inc.

        Attachments

        No reviews matched the request. Check your Options in the drop-down menu of this sections header.

          Activity

            People

            Assignee:
            thiago Thiago Macieira
            Reporter:
            nickcritelli Nicholas Critelli
            Votes:
            0 Vote for this issue
            Watchers:
            5 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:

                Gerrit Reviews

                There are no open Gerrit changes