Uploaded image for project: 'Qt'
  1. Qt
  2. QTBUG-81787

QtQml import has to come after QtQuick in order to avoid Binding's restoreMode warning

    XMLWordPrintable

    Details

    • Commits:
      4e15f2135cdbefd9999a17d4e4fff5ea93679fac (qt/qtdeclarative/5.14)

      Description

      I'm trying to fix the Binding restoreMode warning introduced in 5.14. I added

      QtQml 2.14
      

      to the top of my imports, but I still get an error:

      05:51:691 QQmlApplicationEngine failed to load component
      05:51:691 qrc:/qml/main.qml:264:13: Type Ui.SwatchPanel unavailable
      05:51:691 qrc:/qml/ui/SwatchPanel.qml:100:25: "Binding.restoreMode" is not available in QtQuick 2.14.
      

      Moving the QtQml import below the QtQuick one fixes it, but shouldn't be necessary.

        Attachments

          Issue Links

          For Gerrit Dashboard: QTBUG-81787
          # Subject Branch Project Status CR V

            Activity

              People

              Assignee:
              ulherman Ulf Hermann
              Reporter:
              mitch_curtis Mitch Curtis
              Votes:
              0 Vote for this issue
              Watchers:
              4 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved:

                  Gerrit Reviews

                  There are no open Gerrit changes