Uploaded image for project: 'Qt'
  1. Qt
  2. QTBUG-81856

Service state not updated for manual IP addressing

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Reported
    • Priority: P3: Somewhat important
    • Resolution: Unresolved
    • Affects Version/s: 5.14.0
    • Fix Version/s: None
    • Labels:
      None
    • Environment:
      NVidia TX2 
      Qt 5.14.0
      Connman 1.36
    • Platform/s:
      Linux/Yocto

      Description

      On TX2 the service state is not reported when the interface is ready.

      With the interface ready and in the network, when disconnecting the network cable I get these state changes:

       

      enp1s0 state changed: Configuration
      enp1s0 state changed: Disconnect
      enp1s0 state changed: Idle
      

       

      When reconnecting the cable, the state does not change so it's not possible to detect the interface is ready. Connmanctl reports the the interface/service ready ('R').

      With DHCP method, the state is reported correctly.

      Steps to reproduce:

      1. Set static IP
      2. TX2 Connect to the network
      3. Disconnect the network cable
      4. Reconnect the network cable

        Attachments

        No reviews matched the request. Check your Options in the drop-down menu of this sections header.

          Activity

            People

            Assignee:
            papetaja Pasi Petäjäjärvi
            Reporter:
            damienlefevre Damien LEFEVRE
            Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

              Dates

              Created:
              Updated:

                Gerrit Reviews

                There are no open Gerrit changes