Uploaded image for project: 'Qt'
  1. Qt
  2. QTBUG-82187

Doc: MySQL plugin compilation instructions are outdated

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: P3: Somewhat important
    • Resolution: Fixed
    • Affects Version/s: 5.14.1
    • Fix Version/s: 5.14.2
    • Component/s: SQL Support
    • Labels:
      None

      Description

      https://doc.qt.io/qt-5/sql-driver.html#qmysql currently asks the user to install MySQL 8.0 followed by its C connector.

      However, as of MySQL 8.0.19.0, the C API is not separately installable anymore; it comes bundled with the server [1]. The default folders to use are:

      • MYSQL_INCDIR="C:/Program Files/MySQL/MySQL Server 8.0/include"
      • MYSQL_LIBDIR="C:/Program Files/MySQL/MySQL Server 8.0/lib"

      Furthermore,

      • MySQL 8.0 doesn't provide 32-bit C libraries
      • The Qt docs refer to MySQL 6.1 which doesn't exist [2] (Ignore that; the C connector has a different version numbering system [3])

      (Please double-check this information before updating the docs. It's my first time building the MySQL plugin for Qt)

      [1] https://dev.mysql.com/doc/refman/8.0/en/c-api-implementations.html
      [2] https://en.wikipedia.org/wiki/MySQL#Release_history
      [3] https://downloads.mysql.com/archives/c-c/

        Attachments

        No reviews matched the request. Check your Options in the drop-down menu of this sections header.

          Activity

            People

            Assignee:
            mabrand Mark Brand
            Reporter:
            jksh Sze Howe Koh
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:

                Gerrit Reviews

                There are no open Gerrit changes