Uploaded image for project: 'Qt'
  1. Qt
  2. QTBUG-83098

wasm: apps do not run in 5.14

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: P1: Critical
    • Resolution: Done
    • Affects Version/s: 5.14, 5.15
    • Fix Version/s: 5.14.2
    • Component/s: QPA
    • Labels:
      None
    • Platform/s:
      WebAssembly
    • Commits:
      3a6d8df5219653b043bd642668cee193f563ec84
    • Epic Link:

      Description

      Customer feedback in https://bugreports.qt.io/browse/QTBUG-63917?focusedCommentId=504598&page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel#comment-504598 "Anyone can suggest which emsdk version works for multi threaded build of qt-5.14? I've tried with 1.38.30 but when running on chromium (80.0.3987.149 ) I get this: Application exit (TypeError: Cannot read property 'addEventListener' of null)

      The same version of the SDK for 5.13 works for the same application I've tested (a simple Qt widget project). As to 5.14, latest release of emsdk does not build (something like fastcomp is enabled but LLVM has no support for javascript)"

      <-- Difficult to understand how to setup WebAssembly as a target in Creator.

        Attachments

        No reviews matched the request. Check your Options in the drop-down menu of this sections header.

          Activity

            People

            Assignee:
            lpotter Lorn Potter
            Reporter:
            santtuahonen Santtu Ahonen
            Votes:
            1 Vote for this issue
            Watchers:
            6 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:

                Gerrit Reviews

                There is 1 open Gerrit change