Uploaded image for project: 'Qt'
  1. Qt
  2. QTBUG-83730

WASM: Successful HTTP-Request causes "Uncaught RuntimeError: divide by zero"

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: P2: Important
    • Resolution: Fixed
    • Affects Version/s: 5.15.0 Beta4
    • Fix Version/s: 5.15.0
    • Component/s: Network: HTTP
    • Labels:
      None
    • Environment:
      Windows 10 / Qt 5.15.0 Beta 4 / emsdk 1.39.8
      Chrome Version 81.0.4044.122 (Offizieller Build) (64-Bit)
    • Platform/s:
      WebAssembly

      Description

      The attached example performs a HTTP-Request after starting.

      In the devtools/console the browser shows this error:

      I tested it with(all reproduce it):

      • Qt 5.14.0 Beta 2 Multithreaded (emsdk 1.39.0)
      • Qt 5.15.0 Beta 4 Single/Multithreaded (emsdk 1.39.8)

      The error seems to be without consequence to the app.

        Attachments

        1. ExampleProject.zip
          3 kB
        2. image-2020-04-23-16-03-49-489.png
          image-2020-04-23-16-03-49-489.png
          10 kB
        3. image-2020-04-23-16-04-25-025.png
          image-2020-04-23-16-04-25-025.png
          11 kB
        4. image-2020-07-23-12-11-33-311.png
          image-2020-07-23-12-11-33-311.png
          34 kB
        5. Test_5-15-0-Beta4.zip
          6.35 MB
        6. wasmTestProject.zip
          9 kB
        No reviews matched the request. Check your Options in the drop-down menu of this sections header.

          Activity

            People

            Assignee:
            lpotter Lorn Potter
            Reporter:
            Marscho Marscho
            Votes:
            2 Vote for this issue
            Watchers:
            5 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:

                Gerrit Reviews

                There are no open Gerrit changes