Uploaded image for project: 'Qt'
  1. Qt
  2. QTBUG-84257

tst_Selftests::runSubTest fails with CentOS 8.1 x64 & SLES 15

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Reported
    • Priority: P2: Important
    • Resolution: Unresolved
    • Affects Version/s: 5.15, 6.0.0
    • Fix Version/s: None
    • Component/s: Testing: qtestlib
    • Labels:
      None
    • Environment:
      CentOS 8.1 % SLES 15

      Description

       

      Lots of tst_Selftests::runSubTests fails with CentOS 8.1

       

      http://10.212.0.61:8083/coin/api/results/qt/qtbase/b89e0109e4bddc22f70a872f72cb462305989f50/LinuxCENTOS_8_1x86_64LinuxCENTOS_8_1x86_64GCCqtci-linux-CENTOS-8.1-x86_64-01-728909UseLegacyInstructions/1f08413e0479bcc3881893430e643bea52af79e8/test_1589517094/log.txt.gz

      http://10.212.0.61:8083/coin/integration/qt/qt5/tasks/web_rescheduled_qt_qt5_1589517082533

       

      agent:2020/05/15 06:20:08 build.go:264: FAIL! : tst_Selftests::runSubTest(cmptest all loggers) 'proc.exitStatus() == QProcess::NormalExit' returned FALSE. (Error running cmptest/cmptest -o /tmp/tst_selftests.xfUOma/test_output.txt,txt -o /tmp/tst_selftests.xfUOma/test_output.xml,xml -o /tmp/tst_selftests.xfUOma/test_output.lightxml,lightxml -o -,txt -o /tmp/tst_selftests.xfUOma/test_output.junitxml,junitxml -o /tmp/tst_selftests.xfUOma/test_output.teamcity,teamcity -o /tmp/tst_selftests.xfUOma/test_output.tap,tap with environment DISPLAY=:0 HOME=/home/qt PATH=/home/qt/work/install/bin:/opt/cmake-3.17.0-rc2/bin:/home/qt/.local/bin:/home/qt/bin:/usr/local/bin:/usr/local/sbin:/usr/bin:/usr/sbin:/opt/squish/squish-6.5/bin QT_LOGGING_RULES=*.debug=true;qt.*=false USER=qt XDG_CURRENT_DESKTOP=GNOME XDG_DATA_DIRS=/home/qt/.local/share/flatpak/exports/share/:/var/lib/flatpak/exports/share/:/usr/local/share/:/usr/share/ XDG_MENU_PREFIX=gnome- XDG_RUNTIME_DIR=/run/user/1000 XDG_SEAT=seat0 XDG_SESSION_DESKTOP=gnome XDG_SESSION_ID=3 XDG_SESSION_TYPE=x11 XDG_VTNR=1: Crashed: Process crashed: No protocol specified
       
      agent:2020/05/15 06:20:11 build.go:264: FAIL! : tst_Selftests::runSubTest(keyboard all loggers) 'proc.exitStatus() == QProcess::NormalExit' returned FALSE. (Error running keyboard/keyboard -o /tmp/tst_selftests.xfUOma/test_output.txt,txt -o /tmp/tst_selftests.xfUOma/test_output.xml,xml -o /tmp/tst_selftests.xfUOma/test_output.lightxml,lightxml -o -,txt -o /tmp/tst_selftests.xfUOma/test_output.junitxml,junitxml -o /tmp/tst_selftests.xfUOma/test_output.teamcity,teamcity -o /tmp/tst_selftests.xfUOma/test_output.tap,tap with environment DISPLAY=:0 HOME=/home/qt PATH=/home/qt/work/install/bin:/opt/cmake-3.17.0-rc2/bin:/home/qt/.local/bin:/home/qt/bin:/usr/local/bin:/usr/local/sbin:/usr/bin:/usr/sbin:/opt/squish/squish-6.5/bin QT_LOGGING_RULES=*.debug=true;qt.*=false USER=qt XDG_CURRENT_DESKTOP=GNOME XDG_DATA_DIRS=/home/qt/.local/share/flatpak/exports/share/:/var/lib/flatpak/exports/share/:/usr/local/share/:/usr/share/ XDG_MENU_PREFIX=gnome- XDG_RUNTIME_DIR=/run/user/1000 XDG_SEAT=seat0 XDG_SESSION_DESKTOP=gnome XDG_SESSION_ID=3 XDG_SESSION_TYPE=x11 XDG_VTNR=1: Crashed: Process crashed: No protocol specified
      

       

        Attachments

          Issue Links

          No reviews matched the request. Check your Options in the drop-down menu of this sections header.

            Activity

              People

              Assignee:
              macadder Jason McDonald
              Reporter:
              hehalmet Heikki Halmet
              Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

                Dates

                Created:
                Updated:

                  Gerrit Reviews

                  There are no open Gerrit changes