Uploaded image for project: 'Qt'
  1. Qt
  2. QTBUG-84791

Models Larger than 1000 Rows dont work

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Reported
    • Priority: P2: Important
    • Resolution: Unresolved
    • Affects Version/s: 5.12.6, 5.15.0
    • Fix Version/s: None
    • Component/s: Remote Objects
    • Labels:
      None
    • Platform/s:
      All

      Description

      Trying to replicate any model with more than 1000 rows fails.

      Applying the attached patch causes the modelreplica test to fail to demonstrate the issue:

      Start testing of ModelreplicaTest 
       Config: Using QtTest library 5.12.6, Qt 5.12.6 (x86_64-little_endian-lp64 shared (dynamic) release build; by Clang 10.0.0 (clang-1000.11.45.5) (Apple))
       PASS : ModelreplicaTest::initTestCase()
       QWARN : ModelreplicaTest::basicFunctions(non-templated enableRemoting) qt.remoteobjects: "localhost" is not an IP address, trying to resolve it
       FAIL! : ModelreplicaTest::basicFunctions(non-templated enableRemoting) Compared values are not the same
       Actual (model->data(model->index, Qt::DisplayRole)) : QVariant(QString,Data0)
       Expected (replica->tracks()>data(replica>tracks()->index(i, 0))): QVariant()
       Loc: [tst_modelreplicatest.cpp(92)]
       QWARN : ModelreplicaTest::basicFunctions(templated enableRemoting) qt.remoteobjects: "localhost" is not an IP address, trying to resolve it
       FAIL! : ModelreplicaTest::basicFunctions(templated enableRemoting) Compared values are not the same
       Actual (model->data(model->index, Qt::DisplayRole)) : QVariant(QString,Data0)
       Expected (replica->tracks()>data(replica>tracks()->index(i, 0))): QVariant()
       Loc: [tst_modelreplicatest.cpp(92)]
       QWARN : ModelreplicaTest::nullModel() qt.remoteobjects: "localhost" is not an IP address, trying to resolve it
       QWARN : ModelreplicaTest::nullModel() qt.remoteobjects: QRemoteObjectSourceBase: Cannot replicate a NULL object "tracks"
       PASS : ModelreplicaTest::nullModel()
       PASS : ModelreplicaTest::cleanupTestCase()
       Totals: 3 passed, 2 failed, 0 skipped, 0 blacklisted, 385ms
       Finished testing of ModelreplicaTest

      I can work around this by setting QTRO_NODES_CACHE_SIZE to a larger size (it defaults to 1000) - And I'm not sure if this is a intentional limit, or if there is another bug at play here.

        Attachments

        No reviews matched the request. Check your Options in the drop-down menu of this sections header.

          Activity

            People

            Assignee:
            bstottle Brett Stottlemyer
            Reporter:
            fishwaldo Justin Hammond
            Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

              Dates

              Created:
              Updated:

                Gerrit Reviews

                There are no open Gerrit changes