Uploaded image for project: 'Qt'
  1. Qt
  2. QTBUG-84908

Unreliable loadProgress in WebView on iOS

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Reported
    • Priority: P3: Somewhat important
    • Resolution: Unresolved
    • Affects Version/s: 5.15.0
    • Fix Version/s: None
    • Component/s: WebView
    • Platform/s:
      iOS/tvOS/watchOS

      Description

      User has a payment site. When the site loads quickly in WebView on iOS the loadProgress changes only once to 10.

      On other platforms this works well.

       

      User has done some troubleshooting and found following which is documented in the attachments:

      "The first step shows the output after the load of the page in the WebView upon
      pressing a "Pay" button on a previous Stack page.

      The second step shows the output after we cancelled the payment and returned
      to the previous Stack page (not WebView).

      And this is where the oddity becomes obvious. In the second step's log file,
      you can notice that the previous page's load progress is "completed"
      only upon triggering a change in the "url" of the WebView.

      • This is very unusual, and it happens only on iOS.
      • The same application behaves as expected on Android, Windows and MacOS.
      • Also, I haven't observed this problem two months ago when Qt 5.15 was in
        beta stage."

       

        Attachments

        No reviews matched the request. Check your Options in the drop-down menu of this sections header.

          Activity

            People

            Assignee:
            stromme Christian
            Reporter:
            tero.pelkonen Tero Pelkonen
            Votes:
            1 Vote for this issue
            Watchers:
            3 Start watching this issue

              Dates

              Created:
              Updated:

                Gerrit Reviews

                There are no open Gerrit changes