Uploaded image for project: 'Qt'
  1. Qt
  2. QTBUG-85053

qtharts OpenGL ES

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: P2: Important
    • Resolution: Incomplete
    • Affects Version/s: 5.15.2
    • Fix Version/s: None
    • Component/s: Charts
    • Labels:
      None
    • Environment:
      Orange Pi 4B, Ubuntu 20, LXDE
    • Platform/s:
      Linux/X11

      Description

      As I wrote, qtcharts cannot use OpenGL ES, only OpenGL. True way is switch qtcharts to use OpenGL ES, but now qtcharts from git supports no OpenGL mode, but when I configure my Qt6 from git with -opengl es2 flag, qtcharts wants OpenGL.

      The stupid way is if there is opengl es2 flag so in charts.pro and DEFINES += QT_NO_OPENGL

      So no more OpenGL in qtcharts. But it is not all.

      In qxymodelmapper in QXYModelMapperPrivate::valueFromModel code

       

      return QDateTime(value.toDate()).toMSecsSinceEpoch();

      error no matching conversion for functional-style cast from QDate to QDateTime

      Also this is qxyseries.h

       

      void replace(QList<QPointF> points);
      void replace(QVector<QPointF> points);

       

      error cast member cannon be redeclared

       

      And there are a lot of warnings in qtcharts from clang.

      P.S. Please do qtcharts with LGPL.

       

        Attachments

        No reviews matched the request. Check your Options in the drop-down menu of this sections header.

          Activity

            People

            Assignee:
            e0348803 Miikka Heikkinen
            Reporter:
            dungeonlords Andrei Cherniaev
            Votes:
            0 Vote for this issue
            Watchers:
            4 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:

                Gerrit Reviews

                There are no open Gerrit changes