Uploaded image for project: 'Qt'
  1. Qt
  2. QTBUG-85304

Qt 6.0 static build module "QtQml" plugin "qmlplugin" not found

    XMLWordPrintable

    Details

    • Platform/s:
      Linux/X11
    • Commits:
      6aa4c83bdbd9a8df05c14ac1aaad2f1d44053ec4 (qt/qtdeclarative/dev)

      Description

      I compile qt static version from branch dev in linux and configure in Qt Creator.

      Then my application start after build, I give this error:

      QQmlApplicationEngine failed to load component
      qrc:/main.qml:1:1: module "QtQml" plugin "qmlplugin" not found
      qrc:/main.qml: Failed to load dependencies for module "QtQuick" version 2.15

       

      Env: debian 10

      /Static600/plugins# ls -a
      . .. assetimporters canbus generic iconengines imageformats platforminputcontexts platforms platformthemes qmltooling sqldrivers xcbglintegrations

      Configure options:

      export OPENSSL_LIBS="-L$OPENSSL_DIR/lib -lssl -lcrypto -ldl -lpthread"; \
      ./configure -openssl-linked -static -skip qt3d -no-warnings-are-errors -release -recheck-all -prefix /Static600 -opensource -confirm-license -nomake examples -nomake tests -c++std c++17 -I /usr/include/xcb/ -L /usr/lib/x86_64-linux-gnu/ -xcb-xlib -xcb -feature-thread -feature-xkbcommon -qt-libpng -qt-libjpeg -qt-zlib -I /usr/include/xcb/ -L /usr/lib/x86_64-linux-gnu/
      

       

       

        Attachments

        No reviews matched the request. Check your Options in the drop-down menu of this sections header.

          Activity

            People

            Assignee:
            ulherman Ulf Hermann
            Reporter:
            homdx Homdx Homdx
            Votes:
            1 Vote for this issue
            Watchers:
            2 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:

                Gerrit Reviews

                There are no open Gerrit changes