Uploaded image for project: 'Qt'
  1. Qt
  2. QTBUG-85599

Font-family from style-sheet is not applied to pre blocks in a QTextDocument

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Reported
    • Priority: P3: Somewhat important
    • Resolution: Unresolved
    • Affects Version/s: 5.15.0
    • Fix Version/s: None
    • Labels:
      None
    • Environment:
      Tested on openSUSE Tumbleweed x86.
    • Platform/s:
      Linux/X11

      Description

      When a font-family is indicated in the style-sheet, such font is correctly applied to the html content of a QTextDocument. But that does not happen for the content of <pre></pre> blocks.

      It seems that system mono-space font is always used for pre blocks. I would expect that font-family also affects to pre blocks.

      I have attached a testing example to reproduce the issue (see also screenshot with the result).

       

        Attachments

        1. Screenshot from 2020-07-15 14-12-25.png
          12 kB
          José Iván López González
        2. test.cpp
          0.6 kB
          José Iván López González
        No reviews matched the request. Check your Options in the drop-down menu of this sections header.

          Activity

            People

            Assignee:
            esabraha Eskil Abrahamsen Blomfeldt
            Reporter:
            joseivanlopez José Iván López González
            Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

              Dates

              Created:
              Updated:

                Gerrit Reviews

                There are no open Gerrit changes