Uploaded image for project: 'Qt'
  1. Qt
  2. QTBUG-86732

recommended method to use OGL with QGraphicsView causes errors

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Reported
    • Priority: P2: Important
    • Resolution: Unresolved
    • Affects Version/s: 5.15.1
    • Fix Version/s: None
    • Component/s: Multimedia
    • Labels:
      None
    • Platform/s:
      macOS

      Description

      In the doc on this page it says "To render using OpenGL, simply call setViewport(new QOpenGLWidget)"

      However, doing so only produces a repeating stream of these errors:
      Failed to activate video surface
      QOpenGLFunctions created with non-current context
      QPainterVideoSurface: Vertex shader compile error

      Steps to reproduce:

      1. on mac, on a fresh install of Qt Creator 4.13.1 (5.15.1), open the example "Video Graphics Item"
      2. at the top of VideoPlayer::VideoPlayer, add this code: 
      3. graphicsView->setViewport(new QOpenGLWidget());
      4.  run and open an HD (1920x1080) h.264 movie, and play it

      result: no video, lots of errors in log

       

        Attachments

        No reviews matched the request. Check your Options in the drop-down menu of this sections header.

          Activity

            People

            Assignee:
            valentyn.doroshchuk Valentyn Doroshchuk
            Reporter:
            davecotter David M. Cotter
            Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

              Dates

              Created:
              Updated:

                Gerrit Reviews

                There are no open Gerrit changes