Uploaded image for project: 'Qt'
  1. Qt
  2. QTBUG-86755

no required property support in tools

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Open
    • Priority: P2: Important
    • Resolution: Unresolved
    • Affects Version/s: 5.15.1, 6.0 (Next Major Release)
    • Fix Version/s: 6.1
    • Component/s: QML: Tooling

      Description

      I want to check that properties marked as required is really filled.
      qmlllint can not find any problem in code like this:

      MyTask {
      }
      

      where MyTask has

      Q_PROPERTY(int x MEMBER x_ REQUIRED)
      

      And looks like "required" completly unsupported.
      qmltypes file has no something like "isRequired" for "Property" tag.
      At least qmltyperegistrar generates file without it.
      qmllint have no any mention of "required".
      MetaProperty in qtdeclarative/tools/shared/metatypes.h has no field related to "required".

      Only moc generate right metatypes.json, where "x" marked as required.

        Attachments

        No reviews matched the request. Check your Options in the drop-down menu of this sections header.

          Activity

            People

            Assignee:
            ulherman Ulf Hermann
            Reporter:
            evgeniy_dushistov evgeniy_dushistov
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

              Dates

              Created:
              Updated:

                Gerrit Reviews

                There are no open Gerrit changes