Uploaded image for project: 'Qt'
  1. Qt
  2. QTBUG-86759

Missing QtWebEngineProcess Application in application frameworks

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: P1: Critical
    • Resolution: Done
    • Affects Version/s: 5.15.1
    • Fix Version/s: 5.15.2, 6.1.0 RC
    • Labels:
      None
    • Environment:
      MacBook Pro (16-inch, 2019)
      macOS 10.15.6 (19G2021)
    • Platform/s:
      macOS
    • Commits:
      2727412238300d847493351e706f01d180c64d70 (qt/qttools/dev) f3180b6eb650598ca937943d6cd66da13335d9de (qt/qttools/5.15)

      Description

      When you deploy an application that contains e.g. a QWebEngineView with macdeployqt, the application has a corrupted QtWebEngineProcess application in the Frameworks.

       

      The QtWebEngineProcess.app that is in placed in 

      MyWebEngineApp.app/Contents/Frameworks/QtWebEngineCore.framework/Versions/5/Helpers 

      is empty.

       

      The issue is happening for debug and release build.

        Attachments

        1. WebEngineTest.zip
          2 kB
          Victor Jungbluth
        No reviews matched the request. Check your Options in the drop-down menu of this sections header.

          Activity

            People

            Assignee:
            sorvig Morten Sørvig
            Reporter:
            vjungbluth Victor Jungbluth
            Votes:
            0 Vote for this issue
            Watchers:
            7 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:

                Gerrit Reviews

                There are no open Gerrit changes