Uploaded image for project: 'Qt'
  1. Qt
  2. QTBUG-86815

Rename all internal CMake functions to start with qt_internal

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: P2: Important
    • Resolution: Done
    • Affects Version/s: 6.0
    • Fix Version/s: None
    • Component/s: Build System: CMake
    • Labels:

      Description

      Functions like qt_extend_target and qt_add_module are not meant to be used by user projects. They are internal CMake API meant to build Qt itself.

      To ensure clear separation, we should rename all our functions to contain the qt_internal_ prefix. This way users will clearly know they shouldn't use those functions.

      We've already had some cases where internal API leaked into examples and that didn't break CI, because we currently build examples as part of the internal Qt build, and thus the functions are available in the examples scope.

        Attachments

        No reviews matched the request. Check your Options in the drop-down menu of this sections header.

          Activity

            People

            Assignee:
            alexandru.croitor Alexandru Croitor
            Reporter:
            alexandru.croitor Alexandru Croitor
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:

                Gerrit Reviews

                There are no open Gerrit changes