Uploaded image for project: 'Qt'
  1. Qt
  2. QTBUG-87462

Incorrect #include statements in installed *_pch.h files

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Not Evaluated
    • Resolution: Won't Do
    • Affects Version/s: 5.15.1, 6.0.0 Alpha
    • Fix Version/s: None
    • Component/s: Core: Other
    • Labels:
      None
    • Platform/s:
      Linux/X11

      Description

      Both Qt6 and 5 are affected.

      Some _pch.h files installed by qtbase contain relative paths which are only valid if Qt is uninstalled.

      Qt6:

      /usr/include/qt6 % ls **/*_pch.h | xargs grep "#include \"\.\." 
      QtGui/6.0.0/QtGui/private/qt_gui_pch.h:#include "../../corelib/global/qt_pch.h" 
      QtWidgets/6.0.0/QtWidgets/private/qt_widgets_pch.h:#include "../../gui/kernel/qt_gui_pch.h"

      Qt5:

      /usr/include/qt5 % ls **/*_pch.h | xargs grep "#include \"\.\." 
      QtGui/5.15.1/QtGui/private/qt_gui_pch.h:#include "../../corelib/global/qt_pch.h" 
      QtWidgets/5.15.1/QtWidgets/private/qt_widgets_pch.h:#include "../../gui/kernel/qt_gui_pch.h"

       

      Sounds like these files should not be installed.

       

        Attachments

        No reviews matched the request. Check your Options in the drop-down menu of this sections header.

          Activity

            People

            Assignee:
            thiago Thiago Macieira
            Reporter:
            cgiboudeaux Christophe Giboudeaux
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:

                Gerrit Reviews

                There are no open Gerrit changes