Uploaded image for project: 'Qt'
  1. Qt
  2. QTBUG-87577

Add CI instructions for configuring a top-level cross-compiling Qt (iOS, Android, Yocto)

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Reported
    • Priority: P2: Important
    • Resolution: Unresolved
    • Affects Version/s: 6.0 (Next Major Release)
    • Fix Version/s: None
    • Component/s: Build System: CMake
    • Labels:

      Description

      To make sure we don't regress in top-level configuration of iOS, Android, Yocto configs, we should add CI instructions to configure such top-level configs.
      A pre-req is building and installing top-level host builds, so that the host tools are found during configuration.
      That's tracked in https://bugreports.qt.io/browse/QTBUG-87576

        Attachments

          Issue Links

          No reviews matched the request. Check your Options in the drop-down menu of this sections header.

            Activity

              People

              Assignee:
              alexandru.croitor Alexandru Croitor
              Reporter:
              alexandru.croitor Alexandru Croitor
              Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

                Dates

                Created:
                Updated:

                  Gerrit Reviews

                  There are no open Gerrit changes