Uploaded image for project: 'Qt'
  1. Qt
  2. QTBUG-87579

Qt Android 6 with CMake is relying on deprecated ndk-bundle

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Reported
    • Priority: P2: Important
    • Resolution: Unresolved
    • Affects Version/s: 6.0.0 Beta1
    • Fix Version/s: None
    • Component/s: Build System: CMake
    • Labels:

      Description

      The CMake build for Android added a feature to detect ANDROID_NDK_ROOT (which is used to detect the Android toolchain file) from ANDROID_SDK_ROOT. It tries to look for the ndk-bundle folder which has the default ndk package. However, the ndk-bundle is currently marked as deprecated (obsolete) which means it might be removed in the (near) future. 

      It should be changed to detect the ndk from the <sdk_root>/ndk/<versions> instead.

      Different Qt for Android versions depend on different ndk versions, for Qt 6, ndk r20 and r21 can be used (each has a few sub-versions). Ideally, we could have a CMake function that handles this auto-detection and account for the different ndk versions, and use the latest version found that is supported for a given Qt version.

       

      The patch that introduced the feature: https://codereview.qt-project.org/c/qt/qtbase/+/317248.

        Attachments

        No reviews matched the request. Check your Options in the drop-down menu of this sections header.

          Activity

            People

            Assignee:
            jbornema Joerg Bornemann
            Reporter:
            assam Assam Boudjelthia
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

              Dates

              Created:
              Updated:

                Gerrit Reviews

                There are no open Gerrit changes