Uploaded image for project: 'Qt'
  1. Qt
  2. QTBUG-88409

Outdated minimum X11 requirements

    XMLWordPrintable

    Details

    • Platform/s:
      Linux/X11
    • Commits:
      05bd1e8a443e9e6608a42be62b9d5b4b502a930b (qt/qtdoc/dev) cbd1102e2649dfbe280f3b0d26a62278a8031540 (qt/qtdoc/5.15)

      Description

      In:
      https://doc.qt.io/qt-5/linux-requirements.html

      Minimum xcb-render-util is listed as 0.3.8, but 0.3.9 is needed for building Qt (it probably works with older though):
      https://gitlab.freedesktop.org/xorg/lib/libxcb-render-util/-/commit/8d15acc45a47dc4c922eee5b99885db42bc62c17

      And it is missing xcb-xkb completely. Apparently 1.10 is probably too old, there are extra parameters in some functions and more recent versions don't have.

        Attachments

          Issue Links

          No reviews matched the request. Check your Options in the drop-down menu of this sections header.

            Activity

              People

              Assignee:
              liaqi Liang Qi
              Reporter:
              poikelin Joni Poikelin
              Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved:

                  Gerrit Reviews

                  There are no open Gerrit changes