Uploaded image for project: 'Qt'
  1. Qt
  2. QTBUG-89047

[REG 5.15 -> 6.0.0] Configure fails in oss-fuzz

    XMLWordPrintable

    Details

    • Commits:
      f071ba31b2e441268518217cbe2ec4fe1c978b31 (qt/qtbase/dev) 56d41d9b8b693eba38cf41aa5292843089f2361f (qt/qtbase/6.0)

      Description

      In oss-fuzz, I clone Qt with:

      git clone --branch dev --depth 1 --shallow-submodules --recurse-submodules=qtbase --recurse-submodules=qtsvg git://code.qt.io/qt/qt5.git qt
      

      and then try configuring it with:

      $SRC/qt/configure -qt-libmd4c -platform linux-clang-libc++ -static -opensource -confirm-license -no-opengl -nomake tests -nomake examples -prefix $PWD/qtbase -D QT_NO_DEPRECATED_WARNINGS > configure.log 2>&1
      

      This fails with the attached outputs.

      Running the same parameters locally on Ubuntu 20.04 LTS with CMake 3.19.0 and clang 10.0.0 succeeds.

        Attachments

        1. CMakeError.log
          6 kB
        2. CMakeOutput.log
          54 kB
        3. configure.log
          219 kB
        No reviews matched the request. Check your Options in the drop-down menu of this sections header.

          Activity

            People

            Assignee:
            alexandru.croitor Alexandru Croitor
            Reporter:
            rlohning Robert Löhning
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:

                Gerrit Reviews

                There are no open Gerrit changes