Uploaded image for project: 'Qt'
  1. Qt
  2. QTBUG-89561

Fallback to Qt Quick's software backend needs to be explicit with platform plugins like vnc in Qt 6, unlike Qt 5

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: P2: Important
    • Resolution: Done
    • Affects Version/s: 6.0.0
    • Fix Version/s: 6.1.0 Alpha
    • Component/s: Qt RHI, Quick: SceneGraph
    • Labels:
      None
    • Environment:
      Linux 4.19 on Debian 10, remote host runs Wayland
    • Platform/s:
      Linux/Other display system
    • Commits:
      b23b12dcad8b204e490ea68be31c693d7d809a5b (qt/qtdeclarative/dev)

      Description

      I start my application through VNC (`-platform vnc`). I get this error message.

      If I do not specify the height/width it does work.

        Attachments

        1. screenshot-1.png
          screenshot-1.png
          10 kB
        2. main.qml
          0.1 kB
        For Gerrit Dashboard: QTBUG-89561
        # Subject Branch Project Status CR V

          Activity

            People

            Assignee:
            lagocs Laszlo Agocs
            Reporter:
            roussinm Maxime Roussin-Bélanger
            Votes:
            0 Vote for this issue
            Watchers:
            4 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:

                Gerrit Reviews

                There are no open Gerrit changes