Uploaded image for project: 'Qt'
  1. Qt
  2. QTBUG-89700

Qt Designer: Using deprecated QComboBox::AdjustToMinimumContentsLength created automatically by uic does not compile

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: P4: Low
    • Resolution: Done
    • Affects Version/s: 6.0.0
    • Fix Version/s: 6.0.1, 6.1.0 Alpha
    • Component/s: Tools: Designer
    • Labels:
      None
    • Platform/s:
      All
    • Commits:
      fc36fadeffe76e2b2ab93aefc5c87b83d0503f97 (qt/qtbase/6.0) 179696fcb809d5335dbbeceefb38a216bff81f5f (qt/qtbase/dev) 44ce7a195f166173a4c3975cdc9150753e9b31bd (qt/qttools/6.0) 09b1fb4a3267ebd6dea48709b73105a0281e6b40 (qt/qttools/dev)

      Description

      1/ add a QCombobox to a dialog. and select the option AdjustToMinimumContentsLength...

      2/ run qmake,

      3/ compile...

      error message no member named AdjustToMinimumContentsLength  in QComboBox

      Introduced by "Remove deprecated QComboBox::SizeAdjustPolicy enum value" 1a342b2db14fa92bca717f5daff950b2eef869f7 https://codereview.qt-project.org/c/qt/qtbase/+/297474

        Attachments

          Issue Links

          For Gerrit Dashboard: QTBUG-89700
          # Subject Branch Project Status CR V

            Activity

              People

              Assignee:
              kleint Friedemann Kleint
              Reporter:
              eric_vi eric villa
              Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: