Uploaded image for project: 'Qt'
  1. Qt
  2. QTBUG-90047

boot2qt toolchain has too old cmake for QtCreator

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: P2: Important
    • Resolution: Done
    • Affects Version/s: 5.12.10, 5.12.12
    • Fix Version/s: 5.12.11
    • Component/s: Device Creation
    • Labels:
      None
    • Commits:
      8a5c668b9940537b51167b166718c1993adaa471 (qtsdk/tqtc-qtsdk/master)

      Description

      Starting with version 4.13 Qt Creator requires at least CMake version 3.14.
      Boot2Qt toolchain in 5.12.x are using CMake version 3.10, which is the latest available in the Yocto sumo branch.

      Instead of updating the cmake in the toolchain, let's change the QtCreator Kit configuration so that it uses the CMake bundled in the online installer.

        Attachments

          Issue Links

          No reviews matched the request. Check your Options in the drop-down menu of this sections header.

            Activity

              People

              Assignee:
              rampe Rami Potinkara
              Reporter:
              sapiippo Samuli Piippo
              Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved:

                  Gerrit Reviews

                  There are no open Gerrit changes