Uploaded image for project: 'Qt'
  1. Qt
  2. QTBUG-90564

Crash if some importer plugin can't be loaded

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: P1: Critical
    • Resolution: Done
    • Affects Version/s: 5.15.2
    • Fix Version/s: 5.15.5, 5.15, 6.0.4, 6.1.1, 6.2.0 Alpha
    • Component/s: Quick: 3D
    • Labels:
      None
    • Environment:
      Linux x86_64
    • Platform/s:
      Linux/X11
    • Commits:
      b75f95fd8f39aa186c69d1dbc1bef06c293d716b (qt/qtquick3d/dev) 89ba58a0bdaf4ffea247b24a735e0d95f62358bd (qt/qtquick3d/6.0) 5eb16ea9da8254a7d750d2892c8cefdda334d4ac (qt/qtquick3d/6.1) 7e7a512acea9477b192e580e187f72f901e5cd77 (qt/tqtc-qtquick3d/5.15)
    • Story Points:
      1

      Description

      QtQuick3D makes QML designer crash if some importer plugin can't be loaded (for instance: if the assimp plugin was compiled with system assimp but the assimp library is not installed). The call to  

      importer->inputExtensions

      in https://code.qt.io/cgit/qt/qtquick3d.git/tree/src/assetimport/qssgassetimportmanager.cpp?h=5.15.2#n48 should be guarded by a null-pointer check

        Attachments

        No reviews matched the request. Check your Options in the drop-down menu of this sections header.

          Activity

            People

            Assignee:
            janichol Andy Nichols
            Reporter:
            arojas Antonio Rojas
            Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:

                Gerrit Reviews

                There are no open Gerrit changes