Uploaded image for project: 'Qt'
  1. Qt
  2. QTBUG-90954

Make QSslCertificate plugin-compatible

    XMLWordPrintable

    Details

    • Type: Task
    • Status: Closed
    • Priority: P2: Important
    • Resolution: Done
    • Affects Version/s: 6.1
    • Fix Version/s: 6.1.0 Beta 1
    • Component/s: Network: SSL
    • Labels:
      None
    • Platform/s:
      All
    • Technical Risk:
      Normal
    • Commits:
      41fc143635c25f937a557f09890601f6c7d38736 (qt/qtbase/6.1) 79138e41d6bf9ca60056a5c7fe0f35f3b67a9237 (qt/qtbase/dev)

      Description

      QSslCertificate is the class that has backend-specific code. Unfortunately, it's not properly abstracted and both 'q-class' and 'd-class' are partially implemented in qsslcertificate_backendname.cpp. Instead, both classes should be backend-neutral and use some entities implemented by plugin(s).

        Attachments

          Issue Links

          No reviews matched the request. Check your Options in the drop-down menu of this sections header.

            Activity

              People

              Assignee:
              tpochep Timur Pocheptsov
              Reporter:
              tpochep Timur Pocheptsov
              Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved:

                  Gerrit Reviews