Uploaded image for project: 'Qt'
  1. Qt
  2. QTBUG-91062

qmake should enable c++14, c++17 by default

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: P3: Somewhat important
    • Resolution: Done
    • Affects Version/s: 6.0.0, 6.1.0
    • Fix Version/s: None
    • Component/s: Build tools: qmake
    • Labels:
      None

      Description

      Qt 6 requires a C++17 compiler. However, qmake for user applications still only enables C++11 by default:

      warning(CONFIG =$$CONFIG)
      [...]
      CONFIG =lex yacc debug exceptions depend_includepath testcase_targets import_plugins import_qpa_plugin windows file_copies qmake_use qt warn_on release link_prl flat debug_and_release debug_and_release_target precompile_header autogen_precompile_source embed_manifest_dll embed_manifest_exe shared plugin_manifest win32 msvc copy_dir_files release ReleaseBuild Release build_pass entrypoint c++11 debug qml_debug release ReleaseBuild Release build_pass c++11 console

      It should arguably also enable C++14, C++17 by default.

        Attachments

        No reviews matched the request. Check your Options in the drop-down menu of this sections header.

          Activity

            People

            Assignee:
            kkohne Kai Köhne
            Reporter:
            kkohne Kai Köhne
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:

                Gerrit Reviews

                There are no open Gerrit changes