Uploaded image for project: 'Qt'
  1. Qt
  2. QTBUG-92075

Corrupted Android library in Linux package for 6.1.0 beta2

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: P1: Critical
    • Resolution: Fixed
    • Affects Version/s: 6.1.0 Beta2, 6.1.0 Beta3
    • Fix Version/s: 6.1.0 RC
    • Component/s: Packaging & Installer
    • Labels:
      None
    • Platform/s:
      Android

      Description

      The file 6.1.0/android_arm64_v8a/lib/libQt6Quick3DAssetImport_arm64-v8a.so is corrupted in the Linux package. The Windows package is OK, and copying the library from the Windows installation to the Linux installation fixes the issue.

      The symptom of the bug is that all QtQuick3D applications crash on startup with 64-bit Android. 

      The root cause is probably a buggy NDK on the packaging machine: https://github.com/android/ndk/issues/1148

        Attachments

          Issue Links

          No reviews matched the request. Check your Options in the drop-down menu of this sections header.

            Activity

              People

              Assignee:
              hehalmet Heikki Halmet
              Reporter:
              tvete Paul Olav Tvete
              Votes:
              0 Vote for this issue
              Watchers:
              6 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved:

                  Gerrit Reviews

                  There are no open Gerrit changes