Uploaded image for project: 'Qt'
  1. Qt
  2. QTBUG-92602

Check the basic installation preconditions before the installation starts

    XMLWordPrintable

    Details

    • Technical Risk:
      Normal

      Description

      If the user tries to install Qt to an OS version, which is not supported, the error message is not very easily understandable. The error message is also given after the downloads, when the installation is started.

      • We should tell the user exactly what the problem is. The --verbose switch actually tells the OS version is too old
      • We should do the basic pre-conditions check, like the OS version before the installation. It would be nice to also check, if there is the toolchain, required by the Qt modules to be installed. 

        Attachments

        No reviews matched the request. Check your Options in the drop-down menu of this sections header.

          Activity

            People

            Assignee:
            releaseteam Qt Release Team
            Reporter:
            tpyssysa Tino Pyssysalo
            PM Owner:
            Tino Pyssysalo Tino Pyssysalo
            RnD Owner:
            Jukka Jokiniva Jukka Jokiniva
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

              Dates

              Created:
              Updated:

                Gerrit Reviews

                There are no open Gerrit changes