Uploaded image for project: 'Qt'
  1. Qt
  2. QTBUG-93658

Studio3D does not render when driving Qt Quick via QQuickRenderControl

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Reported
    • Priority: P2: Important
    • Resolution: Unresolved
    • Affects Version/s: 5.15.1, 5.15.2
    • Fix Version/s: None
    • Component/s: Quick: Other
    • Labels:
      None
    • Platform/s:
      Linux/Wayland, Linux/X11, Linux/Other display system

      Description

      Hello,

      I am using a QQuickWindow, QQuickRenderControl and a QOffscreenSurface to render a Qml scene into an OpenGL framebuffer object.For this reason , I am using qt example Qt/Examples/Qt-5.15.2/quick/rendercontrol as a base with some minor modifications.

      What I am trying to do is that using Studio3d inside qml but can not show Studio3d user interface on offscreen surface, only other qml components are rendered correctly.

      If I use QQuickView instead of offscreen surface then Studio3d is rendered correctly.

      For test purposes, I used Qt/Examples/Qt-5.15.1/studio3d/simpleqml/ as a base for Studio3d and combined renderControl example for offscreen surface usage.

      I am attaching test application to reproduce the issue.

      Could you please check the issue and help me on this ?

      Regards

        Attachments

        1. simpleqml.zip
          2.21 MB
          Ekrem Şahin
        No reviews matched the request. Check your Options in the drop-down menu of this sections header.

          Activity

            People

            Assignee:
            qt.team.graphics.and.multimedia Qt Graphics Team
            Reporter:
            ekrems Ekrem Şahin
            Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

              Dates

              Created:
              Updated:

                Gerrit Reviews

                There are no open Gerrit changes