Uploaded image for project: 'Qt'
  1. Qt
  2. QTBUG-93959

Qt Quick should request Vulkan API 1.1 on the VkInstance, when available

    XMLWordPrintable

    Details

    • Commits:
      7a2714d09ed1496b491fecce4cfd8571de470cb9 (qt/qtdeclarative/dev)

      Description

      Qt 6.1 introduces https://doc-snapshots.qt.io/qt6-6.1/qvulkaninstance.html#supportedApiVersion which now allows requesting API versions 1.1 or 1.2 via https://doc-snapshots.qt.io/qt6-6.1/qvulkaninstance.html#setApiVersion in a sensible manner.

      Now, what should Qt Quick request? (when using the default path of letting the Qt Quick scenegraph create a VkInstance)

      The default is API version 1.0. This is good enough for most things but is not future proof. For example, if we start using VK_IMAGE_CREATE_2D_ARRAY_COMPATIBLE_BIT, which is a Vulkan 1.1 constant, in the near future, then at minimum the validation layer's warnings - and in the worst case the whole behavior of the Vulkan implementation - will get affected (in a bad way) due to only requesting API 1.0 on the VkInstance.

      Therefore, the scenegraph's VkInstance creation should check if > 1.0 versions are available, and if so, request API 1.1.

        Attachments

        For Gerrit Dashboard: QTBUG-93959
        # Subject Branch Project Status CR V

          Activity

            People

            Assignee:
            lagocs Laszlo Agocs
            Reporter:
            lagocs Laszlo Agocs
            Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:

                Gerrit Reviews

                There are no open Gerrit changes