Uploaded image for project: 'Qt'
  1. Qt
  2. QTBUG-94071

Japanese characters disappearing when using Qt rendering

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Reported
    • Priority: P2: Important
    • Resolution: Unresolved
    • Affects Version/s: 5.11.3
    • Fix Version/s: None
    • Component/s: GUI: Text handling
    • Labels:
      None
    • Environment:
      TI AM335x running Yocto "thud", Ubuntu 18.04 64-bit running in VMWare
    • Platform/s:
      Linux/X11, Linux/Yocto

      Description

      When using Qt rendering with Japanese characters, sometimes the characters will disappear and be replaced with a black or white box. Then when trying to replace the text with new characters they won't load correctly or at all.

      This issue does not occur when using native rendering but we can't use native rendering because of QTBUG-86633

        Attachments

        1. 20210527_180511.jpg
          20210527_180511.jpg
          5.78 MB
        2. 20210528_103321.jpg
          20210528_103321.jpg
          6.15 MB
        3. 20210528_103354.jpg
          20210528_103354.jpg
          6.65 MB
        4. 20210528_103504.jpg
          20210528_103504.jpg
          6.36 MB
        5. image_9023218.PNG
          image_9023218.PNG
          88 kB
        6. image-2021-06-04-15-15-43-388.png
          image-2021-06-04-15-15-43-388.png
          65 kB
        7. TextCorruptionTest-JP.zip
          5.04 MB
        No reviews matched the request. Check your Options in the drop-down menu of this sections header.

          Activity

            People

            Assignee:
            esabraha Eskil Abrahamsen Blomfeldt
            Reporter:
            theoharbers Theo Harbers
            Votes:
            1 Vote for this issue
            Watchers:
            6 Start watching this issue

              Dates

              Created:
              Updated:

                Gerrit Reviews

                There are no open Gerrit changes