Uploaded image for project: 'Qt'
  1. Qt
  2. QTBUG-94988

initializeEngine not called on iOS

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Not Evaluated
    • Resolution: Incomplete
    • Affects Version/s: 5.14.2
    • Fix Version/s: None
    • Component/s: Quick: Other
    • Labels:
      None
    • Platform/s:
      iOS/tvOS/watchOS

      Description

      I have a custom 'QQmlExtensionPlugin' which encapsulates, amon others, a custom ImageProvider.

      I overrided the methods 'registerTypes' and 'initializeEngine' to register my custom types (the ImageProvider needs to be registered in the QmlEngine, thus i register it through the method 'initializeEngine'.

      The application is developed to work on iOS and Windows. On Windows, both methods 'registerTypes' and 'initializeEngine' are called. But on iOS only 'registerTypes' is called.
      (on iOS the plugin is correctly register through Q_IMPORT_PLUGIN).

        Attachments

        No reviews matched the request. Check your Options in the drop-down menu of this sections header.

          Activity

            People

            Assignee:
            qt.team.quick.subscriptions Qt Quick and Widgets Team
            Reporter:
            jd__ Jérôme Desfieux
            Votes:
            1 Vote for this issue
            Watchers:
            5 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:

                Gerrit Reviews

                There are no open Gerrit changes